Family Banner

Family Banner
Once upon a time...

Thursday, 23 September 2010

Opto Issues

The issues with the optos are ongoing.  I replaced the connection pins with wires on all three my opto circuits, but it appears the one I damaged last time is fubar.

As for the other two:

  • The TechZone optos have the LED enabled until the opto is blocked then it switches off
  • On mine, they're never turn off, no matter what I block them with.
Help!!

2 comments:

  1. Hi Craig,
    Opto End Stops are very delicate and any incorrect wiring will fry them instantly.
    I bought a couple of extra Opto switches from Farnell (link below) to substitute when necessary without inuring the price of the full PCB and shipping costs. They are very easy to substitute if you're handy with a soldering iron. Alternatively let me know and I'll change them for you (I only live about half an hour from you)
    http://uk.farnell.com/fairchild-semiconductor/h21loi/opto-switch-slotted/dp/1021134

    Regards

    Conrad

    ReplyDelete
  2. Hi Conrad,

    While I have a bunch of old Opto's out of printers, I'm in a hurry so I ordered some of the ones you mentioned thanks. Hopefully they will arrive tomorrow while I'm out and about sorting out my camper.

    I will have a go at soldering them and see what happens, if it doens't work I might call on your expertise. The TechZone electronics are so tiny that I do struggle a bit. I probably screwed up the polarity like you suspect.

    Thanks again,
    Craig

    ReplyDelete